Mikrotik > Первичная настройка

Mikrotik > Настройка

Идем по-пунктам:
Сначала, собственно, входим на роутер. Он вам предложит сделать некое подобие быстрой настройки, на что, естественно, можно ответить «да» и дальше воспользоваться этой инструкцией. Для начала, определяем, какой интерфейс у нас будет использоваться под WAN (можно сделать больше одного, но это совсем другая история). Я обычно интерфейс сразу же переименовываю, чтобы потом не запутаться.
Все интерфейсы по-умолчанию в этом роутере называются ether#, где # — его порядковый номер, начиная с единицы. Соответственно, самый левый порт будет ether1.

WAN

StaticIP

Заходим в IP>Adrresses и там нажимаем плюсик.

В поле Address пишем ip по договору и через слеш (/) добавляем битовую маску. Пример: 10.0.0.2/24
В поле Interface выбираем порт, который мы определили под WAN.
Больше ничего не трогаем, нажимаем ОК.
Дальше Заходим в IP>Routes и нажимаем там плюсик.

В поле Dst-address ставим 0.0.0.0/0
В поле Gateway пишем адрес основного шлюза.
Нажимаем ОК, больше ничего делать не нужно.
Настройка сети на роутере завершена.

DynamicIP

Просто делаем как на картинке. отмечаем USE PEER DNS если хотим пользоваться провайдерскими DNS, либо если вы не знаете, что такое DNS.

 

PPPoE

Идем в Interfaces. Добавляем новый PPPoE Client

В GENERAL в Interfaces выбираем наш WAN

В Dial Out вводим логин и пароль, которые дал нам наш провайдер.. Так же отмечаем галочки Use Peer DNS и Add Default Route

Такой настройки должно быть достаточно для большинства провайдеров, но если не завелось, лучше позвонить и уточнить.

 

LAN

Дальше настраиваем домашнюю сеть (LAN)
Заходим в Bridge, нажимаем плюсик.

Называем бридж для лан-портов как хотим. Можно банально LAN.

Ниже для старых прошивок. В новых прошивках просто запихиваем все LAN-порты в один бридж по той же схеме. 
Дальше добавляем в этот бридж любой из портов, которые мы будем настраивать как LAN. Добавляем только один. Например, ether-5.
Этот порт будет мастер-портом в бридже. Дальше идем в Interfaces>Interface и нажимаем на тот самый мастер-порт, проверяем, чтобы master-port в настройках стоял «none».

Дальше мастер закрываем и открываем остальные LAN-интерфейсы по одному. В них уже master-port назначаем наш мастер-порт.

Так делаем с каждым интерфейсом (ох и повезло же человеку, у которого микротик на 24 порта) а так же с беспроводным интерфейсом.
Заходим в IP>Adrresses и там нажимаем плюсик.

В поле Address пишем ip домашней сети и через слеш (/) добавляем битовую маску. Стандартно везде маска 24 бита — это 255.255.255.0
В поле Interface выбираем бридж, который мы определили под LAN.

DHCP

IP>Pool. Там нажимаем плюсик (либо add new)
Задаем там через тире пул для DHCP, который естественно должен совпадать с подсетью LAN

IP>DHCP>Servers. Нажимаем плюсик.

Называем пул, указываем в какой интерфейс он будет раздавать адреса (LAN) и выбираем созданный нами пул.
В DHCP>Networks добавляем подсеть с настройками шлюза и DNS. DNS для простоты можно вписать провайдерские.

Если провайдер дает вам DNS по DHCP и вы явно указали «Use ISP DNS», то можно указать DNS-ом адрес роутера. Теоретически адрес роутера можно укзаать и при схеме со STATIC-IP, чтобы не генерировать запросы на DNS от каждой вашей железки, но тогда придется еще повозиться с фаерволом, а если ты настраиваешь роутер по мануалу, то чем легче, тем лучше.

 

NAT

делаем правило трансляции адресов с LAN на WAN.
Заходим в IP>Firewall>NAT и нажимаем плюсик.

chain: src-nat
Src.Address: ставим тут адрес домашней сети так же вместе с битовой маской
Out. Interface: выбираем WAN-порт.
Если PPPoE, то в качестве порта выбираем PPPoE-интерфейс, который создали.
Тут же переходим во вкладку «Action».

Action: masquerade.
NAT настроен.

 

Настройка Wi-Fi.
Для начала, уточните, есть ли вообще на роутере wi-fi модуль (да, абоны они такие)
Если да, то в Wireless>Interfaces будет отображен скорее всего выключенный интерфейс под беспроводную сеть.
Заходим во вкладку «Security profiles» и либо создаем новый, либо можно отредактировать дефолтный.

Mode: dynamic keys
Authentification: WPAPSK и/или WPA2PSK
Шифры ставим в зависимости от шифрования. AES работает только с WPA2.
Pre-shared-key: пароль от кой-кой сети
ОК. Больше делать ничего не надо.
Открываем Wireless>Interfaces. Включаем интерфейс.
Далее я позволил себе украсть статью из хабра

Очень часто у нынешних «Системных администраторов», возникает проблема с настройкой 802.11 оборудования, попробую объяснить на доходчивом уровне.
В данном посте попробую рассказать, как настроить обычную точку доступа на оборудовании MikroTIk 751,951,2011 etc 802.11 b/g/n

Я приведу пример готовой настройки и расскажу только об основных настройках, так как в рамках одной стати сложно описать весь принцип работы и настройки 802.11.
Прошу не считать данный пост как догму.И так прежде чем настраивать MikroTik, я рекомендую, сбрось настройки WLAN.

Вкладка (Wireless)


Mode: — режим работы нашей карточки выбираем «ap bridge»

Band: — Какие стандарты будут поддерживаться нашей точкой доступа, выбираем «2ghz-b/g/n»

SSID: — Тут всё просто, название нашей сети

Wireless Protocol: какие протоколы для работы будет использоваться наша точка, тут стоит указать только 802.11, так как мы не будем делать «Новогоднюю ёлку из нашей точки доступа», а просто обычная точка доступа.

Country: Выбираем нашу страну. Наверняка возникает вопрос, а зачем? Ответ: Законодательством разных стран, разрешены разные частоты, чтобы нам не получить аплеуху от РОСКОМНАДЗОР-а, MikroTik не даст нам возможности работать с другими частотами.

Antenna Gain: Если у вас есть внешняя антенна обязательно укажите её усиление, с расчётом -0,5, на соединительный узел. А также если вы используете кабель, посмотрите маркировку на кабеле, затухание на единицу измерения (метр, 10 метров etc) кабеля и введите значение с учётом затухания кабеля.

WMM Support: Если вы будите использовать Multicast, то установите эту опцию в Enabled, это даст большие гарантии на доставление этого пакета. Если вы настраиваете MikroTik дома то включите эту опцию, если же это ресторан или конференц зал, то сожрать весь канал может один клиент.

Вкладка (Data Rates)

Здесь всё просто

Rate Selection: выбираем Legaсy расширенная поддержка (для старых устройств), без этой опции старый баркодер не как не хотел ужиться с Mikrotik-ом

Вкладка. (Advanced)


Distance: Очень интересный параметр, если клиенты находятся в одном помещении и примерно на одном расстоянии, ну допустим все в радиусе 20 метров от точки доступа то укажите indoors, если у вас открытая местность поле или конференц зал, и клиенты находятся на разных расстояниях более 0-20 метров то укажите значение dynamic. Ну и третье если клиенты находятся на одном расстоянии, допустим 1км, то так и укажите. Данная опция позволяет Mikrotik по вшитому алгоритму рассчитывать доставлен ли пакет до нужного адресата.

Periodic Calibration: Дело в том, что чип WiFi во время свое работы греется, и из-за этого может частота съезжать немного, соответственно включите эту опцию. Следующее поле оставьте равным одной минуте. Будет происходить калибровка частоты каждую минуту.

Не хотел писать про этот пункт.
Hw. Protection Mode: Данный пункт может помочь в решении проблемы скрытого узла, если указать «rts cts».
Совсем кратко: 802.11 (он же вифи) – это единая среда передачи данных (Вспомните устройство ХАБ), а в стандарте 802.11 указанно, что клиенты сами определяют между собой, кто и когда будет производить запись, НО есть один нюанс это условие будет работать, только если клиенты видят друг друга напрямую. Если же два клиента начнут писать одновременно, то мы получаем коллизию.
Как пример представим себе некое поле (То которое на рабочем столе Windows XP).
На нём располагается точка доступа на рисунке красная точка, и её радиус бледно красным.
А также
Шрайбикус (A), Вася (B), Коля (С)

Шрайбикус и Вася могут быть нормальными участниками и работать в сети без сбоев, но, а вот из-за Коляна могут возникнуть проблемы у всех, дело в том, что Шрайбикус и Вася могут общаться напрямую и определять, кто из них будет вещать в данный промежуток времени. А вот Коля не видит не одного из участников нашей сети, и может смело вещать в любой момент даже в тот, когда Вася или Шрайбикус будут также вещать, из-за этого и появляются коллизии.

Вернёмся к настройке MikroTik значение rts cts, если просто то «Точка доступа сама будет управлять, кому вещать в данный момент», что решит проблему скрытого узла. Данный параметр слегка снизит пропускную способность, и увеличит нагрузку на точку доступа. (Обязательный параметр)

Adaptive Noise Immunity: этот параметр позволяет чипу 802.11, отфильтровывать шумы, ну как пример отражённый сигнал самой точки доступа от соседнего здания. Установите значение равное “ap and client mode”

Вкладка (HT)

Здесь поставить только две галки
HT Tx Chains – Установить галки в chain0 и chain1

HT Rx Chains – Установить галки в chain0 и chain1

У SOHO MikroTik обычно две встроенные антенны, соответственно данный параметр говорит через какие антенны принимать и передавать.

Вкладка (TX Power)


Большинство MIkroTik используют 1W передатчики, но по нашему законодательству, разрешено использовать точки доступа без регистрации не более 0.1W.
В вкратце усиление в 17 dBm – Примерно 0.1W увеличение на три пункта, увеличивает мощность передатчика вдвое.
И того:
18 dBm ~ 0.12W
21 dBm ~ 0.25W
24 dBm ~ 0.5W
27 dBm ~ 1W(по умолчанию обязательно убрать ) — Микроволновка ))))

Настоятельно рекомендую установить значение, равным 15 и если не будет хватать, то поднять не белее 17-19.

Ширина канала выбирается просто, если у нас во всём диапазоне всего пару точек, и всё они без каких, либо косяков, что-то вроде мультикаста и т.п.д.
Каналы 2412-2457 можно использовать как Above
Каналы 2432-2472 можно использовать как Below
Но такую ширину использовать только, когда действительно у вас частота чистая.

Также стоит ещё раз напомнить, что WIFI это единая среда передачи данных. Если вдруг на тех же частотах(2452-2472), появится клиент с 802.11 g, то все участники этой частоты, будут работать со скоростью, что и наш клиент со старенькой карточкой.

К слову, микротик умеет в сканирование сетей:

 


Firewall

Открываем NEW TERMINAL и пихаем туда вот это:

/ip firewall filter
add action=accept chain=input comment="accept established" connection-state=established
add action=accept chain=input comment="accept related" connection-state=related
add action=drop chain=forward comment="drop invalid" connection-state=invalid
add action=accept chain=input comment="accept icmp" protocol=icmp
add action=drop chain=input comment="drop all from WAN" in-interface=[/interface ethernet find default-name=ether1]

Если у вас WAN не ether1, а какой-то другой, то можете переделать это потом в IP>Firewall

 



IPTV

Для начала качаем Extra-Package с mikrotik.com/download
Распаковываем его и вытаскиваем оттуда пакет с IGMP-Proxy
Затем заливаем его в сам микротик, после чего микротик необходимо перезагрузить. Он сам найдет пакет, распакует и установит.
Заходим в Routing>IGMP-Proxy
И добавляем два интерфейса: один WAN, второй LAN. На WAN ставим галочку Upstream. Если надо, можно ограничить прием мультикаста только с определенных подсетей. У нас это подсеть 192.168.0.0/16

Так же говорят, что надо в настройках Firewall внести правило «accept» для порта 1234, но у меня и без него все отлично работает.
На этом сложная настройка IPTV заканчивается.